androidのeclairブランチはjava6でビルドできるっぽい

単に私の手元の環境ではエラーが出なかったから、というだけで公式にできるかは不明だけど…。

gitリポジトリから落としてきたeclairブランチをUbuntu9.10とjava6でビルドしてみたら、特にエラーも出ず完了。

openjdkとsunのjava6のどちらともビルドOKだった。

リポジトリ上でeclairブランチの差分を見てみると、cupcakeやdonutでjava6ビルドエラーの要因になっていた@overrideの記述が削除されているようで、java6対応がなされているようだ。

ただ、donutやcupcakeにはバックポートされてないようなので、これらは今までどおりjava5を使う必要があるみたい。

スポンサーリンク

シェアする

  • このエントリーをはてなブックマークに追加

スポンサーリンク