emergeでSHA256チェックサムが合わないとエラーが出たら

どうもここ数日の間でemergeしようとすると、パッケージのSHA256チェックサムが合わないとエラーが出てemergeが進まない。

ググってみたら、“Gentoo Weekly Newsletter: 1 May 2006”

SHA256 digest issues

A bug in pycrypto caused a lot of digest and Manifest files to be created with bogus SHA256 hashes. The source of the problem has been fixed, users of portage 2.1 may still run into occasional digest failures. Upgrading to pycrypto 2.0.1-r5 is highly recommended.

  • SHA256 digest issues
  • Packages with bad SHA256 hash

と出ていた。

どうもpycryptoのバグなのでpycrypto 2.0.1-r5にアップデートしろ、ということらしい。さっそくpycryptoだけをemergeしなおしたら、他のパッケージのチェックサムエラーも解消したので、emergeでSHA256のエラーが出ているときはpycryptoをemerge。

スポンサーリンク

シェアする

  • このエントリーをはてなブックマークに追加

スポンサーリンク